PT-2010-1818
CVE-2009-5016
·
Published
2010-11-12
·
Updated
2018-10-30
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.2.11
Description
The issue is related to an integer overflow in the
xml utf8 decode function, which can be exploited by remote attackers using a crafted string with overlong UTF-8 encoding. This allows attackers to bypass protection mechanisms against cross-site scripting (XSS) and SQL injection.Recommendations
For PHP versions prior to 5.2.11, update to version 5.2.11 or later to resolve the issue. As a temporary workaround, consider restricting input to prevent the use of overlong UTF-8 encoding.
Found an issue in the description? Have something to add? Feel free to write us 👾