PT-2011-1227
CVE-2011-2713
·
Published
2011-10-21
·
Updated
2014-10-24
Description by
CVSS 2.0
7.1
HighMetricsAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
OpenOffice.org version 3.3.0
LibreOffice versions prior to 3.4.3
Description
The issue is related to an out-of-bounds read in the DOC sprm parser, which can be triggered by a crafted DOC file. This allows a remote attacker to cause a denial of service, resulting in a crash. The vulnerability is exploited through a specially crafted DOC file, allowing an attacker to disrupt service.
Recommendations
For OpenOffice.org version 3.3.0, update to a newer version to mitigate the risk.
For LibreOffice versions prior to 3.4.3, update to version 3.4.3 or later to resolve the issue.
As a temporary workaround, consider avoiding the use of crafted DOC files until a patch is available. Restrict access to untrusted DOC files to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾