PT-2011-1235

CVE-2011-1092

·

Published

2011-03-15

·

Updated

2024-06-15

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.3.6
Description The issue is related to errors in number handling in the ext/shmop/shmop.c component of the PHP programming language interpreter. Exploitation of this issue may allow a remote attacker to cause a denial of service or disclose protected information. Specifically, an integer overflow in the ext/shmop/shmop.c component allows context-dependent attackers to cause a denial of service (crash) and possibly read sensitive memory via a large third argument to the shmop read function.
Recommendations For PHP versions prior to 5.3.6, update to version 5.3.6 or later to resolve the issue. As a temporary workaround, consider restricting the use of the shmop read function with large third arguments to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
DSA-2408-1
OPENSUSE-SU-2024:10290-1
OPENSUSE-SU-2024:10344-1
OPENSUSE-SU-2024:11169-1
Found an issue in the description? Have something to add? Feel free to write us 👾