PT-2011-1306
CVE-2009-5018
·
Published
2011-01-14
·
Updated
2017-08-17
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
gif2png versions 2.5.3 and earlier
Description
A stack-based buffer overflow issue exists in the gif2png.c file of gif2png, potentially allowing attackers to execute arbitrary code through a long command-line argument. This could be exploited in context-dependent scenarios, such as a CGI program that launches gif2png.
Recommendations
For gif2png versions 2.5.3 and earlier, update to a version later than 2.5.3 to resolve the issue.
At the moment, there is no information about a newer version that contains a fix for this vulnerability.
Exploitability
Exploit
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾