PT-2011-1592
CVE-2010-4529
·
Published
2011-01-13
·
Updated
2020-08-07
Description by
CVSS 2.0
2.1
LowMetricsAV:L/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 2.6.37
Description
The issue is related to an integer underflow in the irda getsockopt function, which can allow local users to obtain potentially sensitive information from kernel heap memory. This is achieved via an IRLMP ENUMDEVICES getsockopt call.
Recommendations
For Linux kernel versions prior to 2.6.37, update to version 2.6.37 or later to resolve the issue. As a temporary workaround, consider restricting access to the irda getsockopt function to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾