PT-2011-1613
CVE-2010-4645
·
Published
2011-01-11
·
Updated
2024-06-15
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions 5.2 through 5.2.16
PHP versions 5.3 through 5.3.4
Description
The issue allows context-dependent attackers to cause a denial of service, resulting in an infinite loop, via a certain floating-point value in scientific notation. This value is not properly handled in x87 FPU registers, as demonstrated using the value
2.2250738585072011e-308.Recommendations
For PHP versions 5.2 through 5.2.16, update to version 5.2.17 or later.
For PHP versions 5.3 through 5.3.4, update to version 5.3.5 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾