PT-2011-2021
CVE-2011-0024
·
Published
2011-03-21
·
Updated
2024-06-15
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Wireshark versions prior to 1.2
Description
The issue is related to a heap-based buffer overflow in the wiretap/pcapng.c file, which can be triggered by a crafted capture file. This can cause a denial of service, resulting in an application crash, or potentially allow the execution of arbitrary code.
Recommendations
For versions prior to 1.2, update to version 1.2 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾