PT-2011-2181
CVE-2011-0201
·
Published
2011-06-24
·
Updated
2011-07-23
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Apple Mac OS X versions prior to 10.6.8
Description
The issue is related to an off-by-one error in the CoreFoundation framework, which can be exploited by context-dependent attackers to execute arbitrary code or cause a denial of service, resulting in an application crash. This is achieved through a CFString object that triggers a buffer overflow.
Recommendations
For Apple Mac OS X versions prior to 10.6.8, update to version 10.6.8 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾