PT-2011-2231
CVE-2011-0257
·
Published
2011-08-08
·
Updated
2017-09-19
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Apple QuickTime versions prior to 7.7
Description
The issue is related to an integer signedness error that can be triggered by a crafted PnSize opcode in a PICT file, leading to a stack-based buffer overflow. This can result in the execution of arbitrary code or cause a denial of service, such as an application crash.
Recommendations
For Apple QuickTime versions prior to 7.7, update to version 7.7 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾