PT-2011-2260
CVE-2011-0311
·
Published
2011-09-02
·
Updated
2017-08-17
Description by
CVSS 2.0
3.5
LowMetricsAV:N/AC:M/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
IBM Java versions prior to 1.4.2 SR13 FP9
IBM Runtimes for Java Technology 5.0.0 versions prior to SR13
IBM Runtimes for Java Technology 6.0.0 versions prior to SR10
Description
The issue allows remote authenticated users to cause a denial of service, potentially resulting in a JVM segmentation fault, memory consumption, or an infinite loop. This is achieved by exploiting a crafted attribute length field in a class file, which triggers a buffer over-read.
Recommendations
For IBM Java versions prior to 1.4.2 SR13 FP9, update to version 1.4.2 SR13 FP9 or later.
For IBM Runtimes for Java Technology 5.0.0 versions prior to SR13, update to SR13 or later.
For IBM Runtimes for Java Technology 6.0.0 versions prior to SR10, update to SR10 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾