PT-2011-2335

CVE-2011-0418

·

Published

2011-05-24

·

Updated

2024-06-15

Description by

CVSS 2.0
4.0
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Pure-FTPd versions prior to 1.0.32 NetBSD 5.1
Description The issue is related to the glob implementation, which does not properly expand expressions containing curly brackets. This allows remote authenticated users to cause a denial of service, specifically memory consumption, by sending a crafted FTP STAT command.
Recommendations For Pure-FTPd versions prior to 1.0.32, update to version 1.0.32 or later to resolve the issue. For NetBSD 5.1, there is no information about a newer version that contains a fix for this issue.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
OPENSUSE-SU-2024:10318-1
Found an issue in the description? Have something to add? Feel free to write us 👾