PT-2011-2430

CVE-2011-0537

·

Published

2011-02-04

·

Updated

2011-02-12

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions MediaWiki versions 1.8.0 through 1.16.2
Description The issue concerns directory traversal vulnerabilities in MediaWiki, specifically in the languages/Language.php and includes/StubObject.php files. These vulnerabilities can be exploited by remote attackers to include and execute arbitrary local PHP files. The exploitation is related to crafted language files and the Language::factory function. The issue is relevant when MediaWiki is running on Windows and possibly Novell Netware.
Recommendations For MediaWiki versions 1.8.0 through 1.16.2, update to version 1.16.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the Language::factory function and limiting the ability to upload or modify language files until a patch is applied. Additionally, restrict access to sensitive PHP files to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾