PT-2011-2570

CVE-2011-0701

·

Published

2011-03-14

·

Updated

2017-11-22

Description by

CVSS 2.0
4.0
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions WordPress versions prior to 3.0.5
Description The issue allows remote authenticated users to read draft or private posts by modifying the attachment id parameter in the media uploader. This is due to a flaw in the wp-admin/async-upload.php file.
Recommendations For versions prior to 3.0.5, update to version 3.0.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the media uploader to minimize the risk of exploitation. Avoid using the modified attachment id parameter in the affected API endpoint until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DSA-2190-1
Found an issue in the description? Have something to add? Feel free to write us 👾