PT-2011-2830

CVE-2011-1044

·

Published

2011-02-18

·

Updated

2020-08-12

Description by

CVSS 2.0
2.1
Low
MetricsAV:L/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 2.6.37
Description The issue concerns the ib uverbs poll cq function in the Linux kernel, which fails to initialize a certain response buffer. This allows local users to obtain potentially sensitive information from kernel memory via vectors that cause this buffer to be only partially filled.
Recommendations For Linux kernel versions prior to 2.6.37, update to version 2.6.37 or later to resolve the issue. As a temporary workaround, consider restricting access to the ib uverbs poll cq function to minimize the risk of exploitation.
Exploitability
Fix
Vendors
Affected products
Related identifiers
RHSA-2011:0330
RHSA-2011:0498
RHSA-2011_0498
RHSA-2011:0927
RHSA-2011_0927
SUSE-SU-2012_1391-1
Found an issue in the description? Have something to add? Feel free to write us 👾