PT-2011-3188

CVE-2011-1522

·

Published

2011-05-03

·

Updated

2011-05-31

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Doctrine versions 1.x prior to 1.2.4 Doctrine versions 2.x prior to 2.0.3
Description The issue allows remote attackers to execute arbitrary SQL commands. This is due to multiple SQL injection vulnerabilities in the modifyLimitQuery function. The vulnerabilities can be exploited via the limit or offset field.
Recommendations For Doctrine version 1.x, update to version 1.2.4 or later. For Doctrine version 2.x, update to version 2.0.3 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
DSA-2223-1
Found an issue in the description? Have something to add? Feel free to write us 👾