PT-2011-3348
CVE-2011-1753
·
Published
2011-06-21
·
Updated
2017-08-17
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
ejabberd versions prior to 2.1.7
ejabberd versions 3.x prior to 3.0.0-alpha-3
exmpp versions prior to 0.9.7
Description
The issue allows remote attackers to cause a denial of service due to memory and CPU consumption. This is achieved through a crafted XML document containing a large number of nested entity references, which is not properly detected during entity expansion.
Recommendations
For ejabberd versions prior to 2.1.7, update to version 2.1.7 or later.
For ejabberd versions 3.x prior to 3.0.0-alpha-3, update to version 3.0.0-alpha-3 or later.
For exmpp versions prior to 0.9.7, update to version 0.9.7 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾