PT-2011-3404
CVE-2011-1843
·
Published
2011-05-03
·
Updated
2011-09-07
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Tinyproxy versions prior to 1.8.3
Description
The issue is related to an integer overflow in the conf.c file, potentially allowing remote attackers to bypass access restrictions under certain circumstances. This is due to improper handling of invalid port numbers in TCP connections.
Recommendations
For versions prior to 1.8.3, update to version 1.8.3 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾