PT-2011-3474

CVE-2011-1918

·

Published

2011-11-02

·

Updated

2013-05-21

Description by

CVSS 2.0
10
High
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions GE Intelligent Platforms Proficy Historian versions prior to 3.5 SIM 17 GE Intelligent Platforms Proficy Historian versions 4.x prior to 4.0 SIM 12
Description The issue is related to a stack-based buffer overflow in the Data Archiver service, which can be triggered by remote attackers sending crafted TCP message traffic. This could lead to a denial of service, causing the daemon to crash, or potentially allow the execution of arbitrary code.
Recommendations For versions prior to 3.5 SIM 17, update to version 3.5 SIM 17 or later. For versions 4.x prior to 4.0 SIM 12, update to version 4.0 SIM 12 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ZDI-11-320
Found an issue in the description? Have something to add? Feel free to write us 👾