PT-2011-3499
CVE-2011-1957
·
Published
2011-06-06
·
Updated
2024-06-15
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Wireshark versions 1.2.x through 1.2.16
Wireshark versions 1.4.x through 1.4.6
Description
The issue allows remote attackers to cause a denial of service, resulting in an infinite loop, via an invalid PDU length. This is related to the dissect dcm main function in the DICOM dissector.
Recommendations
For Wireshark versions 1.2.x through 1.2.16, update to version 1.2.17 or later.
For Wireshark versions 1.4.x through 1.4.6, update to version 1.4.7 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾