PT-2011-3501
CVE-2011-1959
·
Published
2011-06-06
·
Updated
2024-06-15
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Wireshark versions 1.2.x through 1.2.16
Wireshark versions 1.4.x through 1.4.6
Description
The issue is related to the
snoop read function in wiretap/snoop.c, which does not properly handle certain virtualizable buffers. This allows remote attackers to cause a denial of service (application crash) via a large length value in a snoop file that triggers a stack-based buffer over-read.Recommendations
For Wireshark versions 1.2.x through 1.2.16, update to version 1.2.17 or later.
For Wireshark versions 1.4.x through 1.4.6, update to version 1.4.7 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾