PT-2011-3580
CVE-2011-2089
·
Published
2011-05-13
·
Updated
2017-08-29
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
GenVersion.dll version 8.0.138.0 in ICONICS BizViz versions prior to 9.22
GenVersion.dll version 8.0.138.0 in GENESIS32 versions prior to 9.22
Description
The issue is related to a stack-based buffer overflow in the SetActiveXGUID method within the VersionInfo ActiveX control. This can be exploited by remote attackers to execute arbitrary code by providing a long string in the argument.
Recommendations
For ICONICS BizViz versions prior to 9.22, update to version 9.22 or later.
For GENESIS32 versions prior to 9.22, update to version 9.22 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾