PT-2011-3663
CVE-2011-2175
·
Published
2011-06-06
·
Updated
2024-06-15
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Wireshark versions 1.2.x through 1.2.16
Wireshark versions 1.4.x through 1.4.6
Description
The issue is caused by an integer underflow in the
visual read function, which allows remote attackers to cause a denial of service by crashing the application. This is achieved through a malformed Visual Networks file that triggers a heap-based buffer over-read.Recommendations
For Wireshark versions 1.2.x through 1.2.16, update to version 1.2.17 or later.
For Wireshark versions 1.4.x through 1.4.6, update to version 1.4.7 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾