PT-2011-3802
CVE-2011-2363
·
Published
2011-06-21
·
Updated
2024-06-15
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 3.6.18
Thunderbird versions prior to 3.1.11
SeaMonkey versions prior to 2.0.15
Description
The issue is related to a use-after-free vulnerability in the implementation of SVG element lists, specifically in the nsSVGPointList::AppendElement function. This vulnerability can be exploited by remote attackers to cause a denial of service, resulting in an application crash, or possibly to execute arbitrary code. The exploitation involves vectors with a user-supplied callback.
Recommendations
For Mozilla Firefox versions prior to 3.6.18, update to version 3.6.18 or later.
For Thunderbird versions prior to 3.1.11, update to version 3.1.11 or later.
For SeaMonkey versions prior to 2.0.15, update to version 2.0.15 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾