PT-2011-4034
CVE-2011-2703
·
Published
2011-08-01
·
Updated
2021-06-07
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
MapServer versions prior to 4.10.7
MapServer versions 5.x prior to 5.6.7
MapServer versions 6.x prior to 6.0.1
Description
The issue allows remote attackers to execute arbitrary SQL commands. This can be achieved through vectors related to (1) OGC filter encoding or (2) WMS time support.
Recommendations
For MapServer versions prior to 4.10.7, update to version 4.10.7 or later.
For MapServer versions 5.x prior to 5.6.7, update to version 5.6.7 or later.
For MapServer versions 6.x prior to 6.0.1, update to version 6.0.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾