PT-2011-4927

CVE-2011-4315

·

Published

2011-12-08

·

Updated

2024-06-15

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions nginx versions prior to 1.0.10
Description The issue is related to a heap-based buffer overflow in compression-pointer processing. This occurs in the core/ngx resolver.c file of the nginx software. Remote resolvers can potentially cause a denial of service, leading to a daemon crash, or possibly have other unspecified impacts by sending a long response.
Recommendations For versions prior to 1.0.10, update to version 1.0.10 or later to resolve the issue. As a temporary workaround, consider restricting access to the core/ngx resolver.c module to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
OPENSUSE-SU-2012_0237-1
OPENSUSE-SU-2024:10044-1
Found an issue in the description? Have something to add? Feel free to write us 👾