PT-2011-4934
CVE-2011-4335
·
Published
2011-11-28
·
Updated
2019-06-11
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Contao versions prior to 2.10.2
Description
The issue allows remote attackers to inject arbitrary web script or HTML via the PATH INFO to index.php in specific actions, such as teachers.html or teachers/. This can lead to cross-site scripting (XSS) attacks.
Recommendations
For versions prior to 2.10.2, update to version 2.10.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the index.php file for the teachers.html and teachers/ actions until a patch is available. Avoid using the PATH INFO to index.php in these actions to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾