PT-2011-5173

CVE-2011-5026

·

Published

2011-12-29

·

Updated

2017-08-29

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Winn GuestBook versions prior to 2.4.8d
Description A cross-site scripting (XSS) issue exists in the addPost function, allowing remote attackers to inject arbitrary web script or HTML via the name parameter to "index.php".
Recommendations For versions prior to 2.4.8d, update to version 2.4.8d or later to resolve the issue. As a temporary workaround, consider restricting access to the addPost function in "data/functions.php" to minimize the risk of exploitation. Avoid using the name parameter in the "index.php" endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾