PT-2012-1033
CVE-2012-2337
·
Published
2012-05-18
·
Updated
2024-06-15
Description by
CVSS 2.0
7.2
HighMetricsAV:L/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
sudo versions 1.6.x through 1.7.x before 1.7.9p1
sudo versions 1.8.x before 1.8.4p5
Description
The issue allows local users to bypass intended command restrictions by executing a command on a host that has an IPv4 address, due to improper support for configurations that use a netmask syntax. This can lead to a violation of confidentiality, integrity, and availability of protected information. The exploitation of this issue can be carried out locally.
Recommendations
For sudo versions 1.6.x through 1.7.x before 1.7.9p1, update to version 1.7.9p1 or later.
For sudo versions 1.8.x before 1.8.4p5, update to version 1.8.4p5 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾