PT-2012-1038

CVE-2012-6063

·

Published

2012-11-30

·

Updated

2014-02-21

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libssh versions prior to 0.5.3
Description The issue is related to a double free vulnerability in the sftp mkdir function in sftp.c, which can be exploited by remote attackers to cause a denial of service (crash) and possibly execute arbitrary code. The vulnerability can be exploited via unspecified vectors. Additionally, there are multiple vulnerabilities in the libssh package that can lead to violations of confidentiality, integrity, and availability of protected information. These vulnerabilities can be exploited remotely.
Recommendations For libssh versions prior to 0.5.3, update to version 0.5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the sftp mkdir function until a patch is available.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾