PT-2012-1119
CVE-2012-1573
·
Published
2012-03-26
·
Updated
2024-06-15
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
GnuTLS versions prior to 3.0.15
GnuTLS versions prior to 2.12.18
Description
The issue affects the gnutls package in Gentoo Linux, potentially compromising the confidentiality, integrity, and availability of protected information. Exploitation can occur remotely. Specifically,
gnutls cipher.c in libgnutls does not properly handle data encrypted with a block cipher, allowing remote attackers to cause a denial of service via a crafted record, such as a crafted GenericBlockCipher structure.Recommendations
For versions prior to 2.12.18, update to version 2.12.18 or later.
For versions prior to 3.0.15, update to version 3.0.15 or later.
As a temporary workaround, consider restricting access to the
gnutls cipher.c function in libgnutls until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾