PT-2012-1179
CVE-2012-4560
·
Published
2012-11-30
·
Updated
2024-06-15
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
libssh versions prior to 0.5.3
Description
The issue concerns multiple vulnerabilities in the libssh package, which can be exploited remotely. This exploitation may lead to a breach of confidentiality, integrity, and availability of protected information. Specifically, multiple buffer overflows are present, allowing remote attackers to cause a denial of service or possibly execute arbitrary code.
Recommendations
For libssh versions prior to 0.5.3, update to version 0.5.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the libssh package to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾