PT-2012-1224
CVE-2012-0789
·
Published
2012-02-14
·
Updated
2018-01-09
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.3.9
Description
The issue is related to a memory leak in the timezone functionality, which can be exploited by remote attackers to cause a denial of service due to memory consumption. This is achieved by triggering many
strtotime function calls, which are not properly handled by the php date parse tzfile cache. The exploitation of this issue may allow a remote attacker to cause a denial of service.Recommendations
For PHP versions prior to 5.3.9, update to version 5.3.9 or later to resolve the issue. As a temporary workaround, consider restricting the number of
strtotime function calls to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾