PT-2012-1244
CVE-2012-4542
·
Published
2012-08-21
·
Updated
2026-10-18
Description by
CVSS 2.0
4.6
MediumMetricsAV:L/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 3.9
Description
The issue is related to the
scsi ioctl function in the Linux kernel, which does not properly consider the SCSI device class during authorization of SCSI commands. This allows local users to bypass intended access restrictions via an SG IO ioctl call that leverages overlapping opcodes. The vulnerability can be exploited to elevate privileges.Recommendations
For Linux kernel versions prior to 3.9, update to a version 3.9 or later to resolve the issue.
As a temporary workaround, consider restricting access to the SG IO ioctl call to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾