PT-2012-1314
CVE-2010-4823
·
Published
2012-09-17
·
Updated
2017-08-29
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
SilverStripe versions 2.3.x through 2.3.9
SilverStripe versions 2.4.x through 2.4.3
Description
A cross-site scripting (XSS) issue exists in the httpError method, allowing remote attackers to inject arbitrary web script or HTML via missing URL actions when custom error handling is not used.
Recommendations
For SilverStripe versions 2.3.x through 2.3.9, update to version 2.3.10 or later.
For SilverStripe versions 2.4.x through 2.4.3, update to version 2.4.4 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾