PT-2012-1334

CVE-2010-5091

·

Published

2012-08-26

·

Updated

2012-08-27

Description by

CVSS 2.0
6.0
Medium
MetricsAV:N/AC:M/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions SilverStripe versions 2.3.x through 2.3.7 SilverStripe versions 2.4.x through 2.4.0
Description The issue allows remote authenticated users with CMS author privileges to execute arbitrary PHP code. This is achieved by changing the extension of an uploaded file through the setName function in filesystem/File.php.
Recommendations For SilverStripe versions 2.3.x through 2.3.7, update to version 2.3.8 or later. For SilverStripe versions 2.4.x through 2.4.0, update to version 2.4.1 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾