PT-2012-1830

CVE-2011-4282

·

Published

2012-07-16

·

Updated

2022-05-13

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions 2.0.x through 2.0.1
Description The issue concerns multiple cross-site scripting (XSS) vulnerabilities in the course-tags functionality. These vulnerabilities allow remote attackers to inject arbitrary web script or HTML via the sort or show parameters in the tag/coursetags more.php file.
Recommendations For Moodle versions 2.0.x through 2.0.1, update to version 2.0.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the tag/coursetags more.php file to minimize the risk of exploitation. Avoid using the sort and show parameters in the affected functionality until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-6XQG-F34F-5FJX
Found an issue in the description? Have something to add? Feel free to write us 👾