PT-2012-1845
CVE-2011-4297
·
Published
2012-07-16
·
Updated
2022-05-13
Description by
CVSS 4.0
6.6
MediumMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Name of the Vulnerable Software and Affected Versions
Moodle versions 2.0.x through 2.0.3
Moodle versions 2.1.x through 2.1.0
Description
The issue allows remote attackers to post a comment by leveraging the guest role and operating on a front-page activity, due to improper restriction of comment capabilities in the comment/lib.php file.
Recommendations
For Moodle versions 2.0.x through 2.0.3, update to version 2.0.4 or later.
For Moodle versions 2.1.x through 2.1.0, update to version 2.1.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾