PT-2012-2022
CVE-2011-4961
·
Published
2012-09-17
·
Updated
2012-10-15
Description by
CVSS 2.0
6.0
MediumMetricsAV:N/AC:M/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
SilverStripe versions 2.3.x through 2.3.11
SilverStripe versions 2.4.x through 2.4.5
Description
The issue allows remote authenticated users with the EDIT PERMISSIONS permission to gain administrator privileges. This is achieved via a TreeMultiselectField that includes admin groups when adding a user to the selected groups.
Recommendations
For SilverStripe versions 2.3.x through 2.3.11, update to version 2.3.12 or later.
For SilverStripe versions 2.4.x through 2.4.5, update to version 2.4.6 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾