PT-2012-2438

CVE-2012-0247

·

Published

2012-05-07

·

Updated

2024-06-15

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions 6.7.5 and earlier
Description The issue allows remote attackers to cause a denial of service, potentially leading to memory corruption, and possibly execute arbitrary code. This is achieved through crafted offset and count values in the ResolutionUnit tag within the EXIF IFD0 of an image.
Recommendations For ImageMagick versions 6.7.5 and earlier, update to a version later than 6.7.5 to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
CESA-2012_0544
DSA-2427-1
OPENSUSE-SU-2024:10040-1
RHSA-2012:0544
RHSA-2012_0544
RHSA-2012:0545
RHSA-2012_0545
SUSE-SU-2012_0763-1
SUSE-SU-2012_0764-1
Found an issue in the description? Have something to add? Feel free to write us 👾