PT-2012-2589

CVE-2012-0468

·

Published

2012-04-24

·

Updated

2024-06-15

Description by

CVSS 2.0
10
High
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Mozilla Firefox versions 4.x through 11.0 Thunderbird versions 5.0 through 11.0 SeaMonkey versions prior to 2.9
Description The issue allows remote attackers to cause a denial of service or possibly execute arbitrary code via vectors related to jsval.h and the js::array shift function.
Recommendations For Mozilla Firefox versions 4.x through 11.0, update to a version outside of this range to resolve the issue. For Thunderbird versions 5.0 through 11.0, update to a version outside of this range to resolve the issue. For SeaMonkey versions prior to 2.9, update to version 2.9 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
CESA-2012_0515
CESA-2012_0516
OPENSUSE-SU-2014_1100-1
OPENSUSE-SU-2024:10071-1
OPENSUSE-SU-2024:10230-1
RHSA-2012:0515
RHSA-2012_0515
RHSA-2012:0516
RHSA-2012_0516
Found an issue in the description? Have something to add? Feel free to write us 👾