PT-2012-2770
CVE-2012-0663
·
Published
2012-05-16
·
Updated
2017-09-19
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Apple QuickTime versions prior to 7.7.2
Description
The issue is related to multiple stack-based buffer overflows that can be triggered via crafted TeXML files, potentially allowing remote attackers to execute arbitrary code or cause a denial of service, such as an application crash. The vulnerability is exploited through the parsing of specific elements in TeXML files, including sampleData, transform attributes, Karaoke elements, and Style elements.
Recommendations
For Apple QuickTime versions prior to 7.7.2, update to version 7.7.2 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾