PT-2012-2931

CVE-2012-0897

·

Published

2012-01-20

·

Updated

2017-08-29

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions IrfanView PlugIns versions prior to 4.33
Description The issue is related to a stack-based buffer overflow in the JPEG2000 plugin. This can be exploited by remote attackers through a specially crafted JPEG2000 (JP2) file, specifically by manipulating the Quantization Default (QCD) marker segment, allowing them to execute arbitrary code.
Recommendations For versions prior to 4.33, update to version 4.33 or later to resolve the issue. As a temporary workaround, consider avoiding the use of the JPEG2000 plugin until the update is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾