PT-2012-3036
CVE-2012-1039
·
Published
2012-03-19
·
Updated
2018-01-11
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Dotclear versions prior to 2.4.2
Description
The issue allows remote attackers to inject arbitrary web script or HTML. This can be achieved via several parameters, including the
login data parameter to "admin/auth.php", the nb parameter to "admin/blogs.php", the type, sortby, order, or status parameters to "admin/comments.php", or the page parameter to "admin/plugin.php".Recommendations
For versions prior to 2.4.2, update to version 2.4.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the affected admin pages until the update is applied. Avoid using the specified parameters in the affected API endpoints until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾