PT-2012-3056

CVE-2012-1068

·

Published

2012-02-14

·

Updated

2017-08-29

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions WP-RecentComments plugin versions prior to 2.0.7
Description The issue is related to a cross-site scripting (XSS) vulnerability in the rc ajax function, which allows remote attackers to inject arbitrary web script or HTML via the page parameter. This is specifically related to AJAX paging.
Recommendations For WP-RecentComments plugin versions prior to 2.0.7, update to version 2.0.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the rc ajax function in core.php to minimize the risk of exploitation. Avoid using the page parameter in the affected AJAX endpoint until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾