PT-2012-3081

CVE-2012-1098

·

Published

2012-03-13

·

Updated

2019-08-08

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 3.0.x through 3.0.11 Ruby on Rails versions 3.1.x through 3.1.3 Ruby on Rails versions 3.2.x through 3.2.1
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.
Recommendations For Ruby on Rails versions 3.0.x through 3.0.11, update to version 3.0.12 or later. For Ruby on Rails versions 3.1.x through 3.1.3, update to version 3.1.4 or later. For Ruby on Rails versions 3.2.x through 3.2.1, update to version 3.2.2 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-QV8P-V9QW-WC7G
Found an issue in the description? Have something to add? Feel free to write us 👾