PT-2012-3082

CVE-2012-1099

·

Published

2012-03-13

·

Updated

2019-08-08

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 3.0.x through 3.0.11 Ruby on Rails versions 3.1.x through 3.1.3 Ruby on Rails versions 3.2.x through 3.2.1
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements. This is due to a vulnerability in the select helper in actionpack/lib/action view/helpers/form options helper.rb.
Recommendations For Ruby on Rails versions 3.0.x through 3.0.11, update to version 3.0.12 or later. For Ruby on Rails versions 3.1.x through 3.1.3, update to version 3.1.4 or later. For Ruby on Rails versions 3.2.x through 3.2.1, update to version 3.2.2 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2XJJ-5X6H-8VMF
DSA-2466-1
Found an issue in the description? Have something to add? Feel free to write us 👾