PT-2012-3354
CVE-2012-1580
·
Published
2012-09-09
·
Updated
2017-08-29
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
MediaWiki versions 1.17.x through 1.17.2
MediaWiki versions 1.18.x through 1.18.1
Description
A cross-site request forgery (CSRF) issue exists in the Special:Upload feature, allowing remote attackers to hijack the authentication of victims for file upload requests.
Recommendations
For MediaWiki versions 1.17.x through 1.17.2, update to version 1.17.3 or later.
For MediaWiki versions 1.18.x through 1.18.1, update to version 1.18.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾