PT-2012-3355
CVE-2012-1581
·
Published
2012-09-09
·
Updated
2017-08-29
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
MediaWiki versions 1.17.x through 1.17.2
MediaWiki versions 1.18.x through 1.18.1
Description
The issue allows remote attackers to change the passwords of arbitrary users due to the use of weak random numbers for password reset tokens.
Recommendations
For MediaWiki versions 1.17.x through 1.17.2, update to version 1.17.3 or later.
For MediaWiki versions 1.18.x through 1.18.1, update to version 1.18.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾