PT-2012-3704
CVE-2012-1974
·
Published
2012-08-28
·
Updated
2024-10-21
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 15.0
Firefox ESR 10.x versions prior to 10.0.7
Thunderbird versions prior to 15.0
Thunderbird ESR 10.x versions prior to 10.0.7
SeaMonkey versions prior to 2.12
Description
The issue allows remote attackers to execute arbitrary code or cause a denial of service due to heap memory corruption via unspecified vectors. This is related to a use-after-free vulnerability in the
gfxTextRun::CanBreakLineBefore function.Recommendations
For Mozilla Firefox versions prior to 15.0, update to version 15.0 or later.
For Firefox ESR 10.x versions prior to 10.0.7, update to version 10.0.7 or later.
For Thunderbird versions prior to 15.0, update to version 15.0 or later.
For Thunderbird ESR 10.x versions prior to 10.0.7, update to version 10.0.7 or later.
For SeaMonkey versions prior to 2.12, update to version 2.12 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾