PT-2012-3895

CVE-2012-2234

·

Published

2012-04-22

·

Updated

2017-12-13

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions TeamPass versions prior to 2.1.6
Description A cross-site scripting (XSS) issue allows remote authenticated users to inject arbitrary web script or HTML via the login parameter in an "add new user" action. This occurs in the sources/users.queries.php file.
Recommendations For versions prior to 2.1.6, update to version 2.1.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the "add new user" action to minimize the risk of exploitation. Avoid using the login parameter in the affected action until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾